$re = '/[([{].*?[)}\]]/';
$str = '\'foo (bar) baz (xyz)\'
\'foo [bar] baz [xyz]\'
\'foo {bar} baz {xyz}\'';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);