package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?(DEFINE)(?<Digit>one|two|three|four|five|six|seven|eight|nine))(?(DEFINE)(?<Teen>twenty|thirty|forty|fifty|sixty|seventy|eighty|ninety))(?(DEFINE)(?<TwoDigits>((?&Teen)-)?(?&Digit)|ten|eleven|twelve|thirteen|fourteen|fifteen|sixteen|seventeen|eighteen|nineteen|(?&Teen)))(?(DEFINE)(?<ThreeDigits>((?&Digit) hundred (and )?)?(?&TwoDigits)|(?&Digit) hundred))(?(DEFINE)(?<SixDigits>((?&ThreeDigits) thousand (and )?)?(?&ThreeDigits)|(?&ThreeDigits) thousand))(?(DEFINE)(?<TwelveDigits>((?&SixDigits) million (and )?)?(?&SixDigits)|(?&SixDigits) million))(?&TwelveDigits)`)
var str = `three
eleven
eighty-two
four hundred sixty-nine
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}