re = /^(?:(?!\-)(?:(?!\:\.)[a-zA-Z0-9\-])*[^-]\.)*(?:(?!\-)(?:[a-zA-Z0-9\-]*(?<=[a-zA-Z])[0-9]*)+(?<!\-))$/
str = 'plfgr.eu.org'
# Print the match result
str.match(re) do |match|
puts match.to_s
end