re = /^([A-Za-z0-9_\-\.])+\@([A-Za-z0-9_\-\.])+\.([A-Za-z]{2,4})$/
str = 'testé@text.com'
# Print the match result
str.match(re) do |match|
puts match.to_s
end