import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?=.*\\b[1-9]\\b)(?=.*\\b1[0-7]\\b)[0-9]+(?:,[0-9]+)+$";
final String string = "1\n"
+ "2\n"
+ "3\n"
+ "4\n"
+ "5\n"
+ "6\n"
+ "7\n"
+ "8\n"
+ "9\n"
+ "10\n"
+ "1,1\n"
+ "1,2\n"
+ "1,3\n"
+ "2,12\n"
+ "11,13,15\n"
+ "7,8,12\n"
+ "12,15\n"
+ "14,16,17\n"
+ "15,6\n"
+ "13,11,10,2";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}