#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\<(\w+)(?:\s*|\>)?"
Local $sString = "" & @CRLF & _
"<!DOCTYPE html>" & @CRLF & _
"<html lang="el" dir="ltr" class="no-js">" & @CRLF & _
"<head>" & @CRLF & _
" <meta charset="utf-8" />" & @CRLF & _
" <title>Radial</title>" & @CRLF & _
" <meta name="description" content="Η Radial σχεδιάζει και αναπτÏσσει websites, οÏγανώνει online καμπάνιες και δημιουÏγεί εταιÏικÎÏ‚ ταυτότητες." />" & @CRLF & _
" " & @CRLF & _
" <meta property="fb:page_id" content="118981334805256" />" & @CRLF & _
" <meta property="fb:app_id" content="166019300145537" />" & @CRLF & _
" " & @CRLF & _
" " & @CRLF & _
" <!--[if lt IE 9]><script type="text/javascript" src="http://html5shiv.googlecode.com/svn/trunk/html5.js"></script><![endif]-->" & @CRLF & _
" <script type="text/javascript">(function(H){H.className=H.className.replace(/\bno-js\b/,'js')})(document.documentElement);</script>" & @CRLF & _
" " & @CRLF & _
" <link rel="stylesheet" type="text/css" media="screen" href="http://static.radial.gr/styles/screen.css?43614" />" & @CRLF & _
" " & @CRLF & _
" <script type="text/javascript" src="http://use.typekit.com/ioa2dxy.js"></script>" & @CRLF & _
" <script type="text/javascript">try{Typekit.load();}catch(e){}</script?" & @CRLF & _
" " & @CRLF & _
" <link rel="alternate" type="application/rss+xml" title="Τελευταία ÎÏγα" href="/feed/" />" & @CRLF & _
" " & @CRLF & _
" " & @CRLF & _
" " & @CRLF & _
"</head>" & @CRLF & _
"" & @CRLF & _
"<body id="home" class="">" & @CRLF & _
"" & @CRLF & _
"<header id="main-header"><div class="wrapper">" & @CRLF & _
" <div id="logo"><a href="/"><img src="http://static.radial.gr/images/radial-logo.png" alt="Radial" /></a></div>" & @CRLF & _
" <nav id="main-nav">" & @CRLF & _
" <ul>" & @CRLF & _
" <li><a href="/projects/">ΈÏγα</a></li>" & @CRLF & _
" <li><a href="/profile/">Î Ïοφίλ</a></li>" & @CRLF & _
" <li><a href="/contact/">Επικοινωνία</a></li>" & @CRLF & _
" </ul>" & @CRLF & _
" </nav>" & @CRLF & _
" <nav id="lang-nav">" & @CRLF & _
" <span>EΛ</span>" & @CRLF & _
" <a href="/en/">EN</a>" & @CRLF & _
" </nav>" & @CRLF & _
"" & @CRLF & _
"<br />" & @CRLF & _
"" & @CRLF & _
"</div></header>" & @CRLF & _
"" & @CRLF & _
"<script type="text/javascript">" & @CRLF & _
" " & @CRLF & _
" var _gaq = _gaq || [];" & @CRLF & _
" _gaq.push(['_setAccount', 'UA-515952-44']);" & @CRLF & _
" _gaq.push(['_trackPageview']);" & @CRLF & _
" (function() {" & @CRLF & _
" var ga = document.createElement('script'); ga.type = 'text/javascript'; ga.async = true;" & @CRLF & _
" ga.src = ('https:' == document.location.protocol ? 'https://ssl' : 'http://www') + '.google-analytics.com/ga.js';" & @CRLF & _
" var s = document.getElementsByTagName('script')[0]; s.parentNode.insertBefore(ga, s);" & @CRLF & _
" })();" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"</script>" & @CRLF & _
"" & @CRLF & _
"</body>" & @CRLF & _
"</html>" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")