import re
regex = re.compile(r"(\[\[outlook:)([0-9A-Z]*)(\]\[)(.*)(\]\])")
test_str = ("[[outlook:000000003730C053465F314590D066368CF3097B0700AAF83E03F96EDC42918E044642DEDDB3000013E2000E0000AAF83E03F96EDC42918E044642DEDDB3000013E2EFD30000][MESSAGE: RE: Subject of the Message (Sendername Senderfirstname) 2014-08-05 19:48]]\n\n"
"[[http:000000003730C053465F314590D066368CF3097B0700AAF83E03F96EDC42918E044642DEDDB3000013E2000E0000AAF83E03F96EDC42918E044642DEDDB3000013E2EFD30000][MESSAGE: RE: Subject of the Message (Sendername Senderfirstname) 2014-08-05 19:48]]")
subst = "[[path\\\\outlook\\\\\\2\\.msg\\3\\4\\5"
result = regex.sub(subst, test_str)
if result:
print(result)