$re = '/[A-Za-z]+/';
$str = 'a+(b * 6) <= cat*45 && cat = dog';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);