package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)1(0+)1`)
var str = `1010010001`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}