#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "[^A-Za-z0-9-$_ ]|" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
""
Local $sString = "" & @CRLF & _
"3340273*625-1076781-2 " & @CRLF & _
""
Local $sSubst = "a-zA-Z0-9@\$"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)