package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?-xism:\b(print|time)\b)`)
var str = `print $time . "\n";
$epoc = time();`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}