const regex = new RegExp('(?<=div)\\.(?=\\d)', 'gm')
const str = `div.1
div.2
div.3`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);