$re = '/^-?(?:\d+\.?\d*)?$/m';
$str = '
-
1
1.2
-8.
test
1234567890
1.123
-2
-2.6';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);