$re = '/^[0-9]{3}\s?[0-9]{2}$/';
$str = '566 33';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);