const regex = /^(0[1-9]|1[0-2])\/(0[1-9]|1\d|2\d|3[01])\/(19|20)\d{2}$/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(0[1-9]|1[0-2])\\\/(0[1-9]|1\\d|2\\d|3[01])\\\/(19|20)\\d{2}$', '')
const str = `01/1/1901`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}