$re = '/^username (\w+(?!networks))/m';
$str = 'username network
username banana
username networks
username apple
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);