use strict;
my $str = 'utm_tags=123&utm_src=aaa
utm_tags=123&random=random&utm_src=aaa
v=12.35&utm_src=aaa&utm_tags=123
utm_tags=123
utm_src=aaa';
my $regex = qr/(^|&)(?!(v|utm_[^=]+)=)[^=]+=/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}