re = /[a-z]+[A-Z][a-zA-Z]*/
str = 'someCamelCasedString & _someCamelCasedString & $someCamelCasedString. Th
: Foo._someCamelCasedString.bar or Foo[_someCamelCasedString].bar'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end