#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "<[^>]*>|([^<]+)"
Local $sString = "aaa" & @CRLF & _
"<bbb>" & @CRLF & _
"aaa<bbb>" & @CRLF & _
"<bbb>aaa" & @CRLF & _
"aaa<bbb><ccc>" & @CRLF & _
"<bbb>aaa<ccc>" & @CRLF & _
"<bbb><ccc>aaa"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")