re = /^[a-zA-Z0-9_-]+(?:\s[a-zA-Z0-9_-]+)*$/m
str = 'foo bar
foo bar
foo bar
foo bar '
# Print the match result
str.scan(re) do |match|
puts match.to_s
end