import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\d\\.*\\d)*.+(fa-.+)\\s\\[&#x(.{4});\\]";
final String string = " fa-500px []\n"
+ " fa-adjust []\n"
+ " fa-adn []\n"
+ " fa-align-center []\n"
+ " fa-align-justify []\n"
+ " fa-align-left []\n"
+ " fa-align-right []\n"
+ "4.4 fa-amazon []\n"
+ " fa-ambulance []\n"
+ "4.6 fa-american-sign-language-interpreting []\n"
+ " fa-anchor []\n"
+ " fa-android []\n"
+ "4.2 fa-angellist []\n"
+ " fa-angle-double-down []\n"
+ " fa-angle-double-left []\n"
+ " fa-angle-double-right []\n"
+ " fa-angle-double-up []\n"
+ " fa-angle-down []\n"
+ " fa-angle-left []\n"
+ " fa-angle-right []\n"
+ " fa-angle-up []\n"
+ " fa-apple []\n"
+ " fa-archive []\n"
+ "4.2 fa-area-chart []\n"
+ " fa-arrow-circle-down []\n"
+ " fa-arrow-circle-left []\n"
+ " fa-arrow-circle-o-down []\n"
+ "4.0 fa-arrow-circle-o-left []\n"
+ "4.0 fa-arrow-circle-o-right []\n"
+ " fa-arrow-circle-o-up []\n"
+ " fa-arrow-circle-right []\n"
+ " fa-arrow-circle-up []\n"
+ " fa-arrow-down []\n"
+ " fa-arrow-left []\n"
+ " fa-arrow-right []\n"
+ " fa-arrow-up []\n"
+ " fa-arrows []\n"
+ " fa-arrows-alt []\n"
+ " fa-arrows-h []\n"
+ " fa-arrows-v []\n"
+ "4.6 fa-asl-interpreting (alias) []\n"
+ "4.6 fa-assistive-listening-systems []\n"
+ " fa-asterisk []\n"
+ "4.2 fa-at []\n"
+ "4.6 fa-audio-description []\n"
+ "4.1 fa-automobile (alias) []\n"
+ " fa-backward []\n"
+ "4.4 fa-balance-scale []\n"
+ " fa-ban []\n"
+ "4.1 fa-bank (alias) []\n"
+ " fa-bar-chart []\n"
+ " fa-bar-chart-o (alias) []\n"
+ " fa-barcode []\n"
+ " fa-bars []\n"
+ "4.4 fa-battery-0 (alias) []\n"
+ "4.4 fa-battery-1 (alias) []\n"
+ "4.4 fa-battery-2 (alias) []\n"
+ "4.4 fa-battery-3 (alias) []\n"
+ "4.4 fa-battery-4 (alias) []\n"
+ "4.4 fa-battery-empty []\n"
+ "4.4 fa-battery-full []\n"
+ "4.4 fa-battery-half []\n"
+ "4.4 fa-battery-quarter []\n"
+ "4.4 fa-battery-three-quarters []\n"
+ "4.3 fa-bed []\n"
+ " fa-beer []\n"
+ "4.1 fa-behance []\n"
+ "4.1 fa-behance-square []\n"
+ " fa-bell []\n"
+ " fa-bell-o []\n"
+ "4.2 fa-bell-slash []\n"
+ "4.2 fa-bell-slash-o []\n"
+ "4.2 fa-bicycle []\n"
+ "4.2 fa-binoculars []\n"
+ "4.2 fa-birthday-cake []\n"
+ " fa-bitbucket []\n"
+ " fa-bitbucket-square []\n"
+ " fa-bitcoin (alias) []\n"
+ "4.4 fa-black-tie []\n"
+ "4.6 fa-blind []\n"
+ "4.5 fa-bluetooth []\n"
+ "4.5 fa-bluetooth-b []\n"
+ " fa-bold []\n"
+ " fa-bolt []\n"
+ "4.1 fa-bomb []\n"
+ " fa-book []\n"
+ " fa-bookmark []\n"
+ " fa-bookmark-o []\n"
+ "4.6 fa-braille []\n"
+ " fa-briefcase []\n"
+ " fa-btc []\n"
+ " fa-bug []\n"
+ "4.1 fa-building []\n"
+ " fa-building-o []\n"
+ " fa-bullhorn []\n"
+ " fa-bullseye []\n"
+ "4.2 fa-bus []\n"
+ "4.3 fa-buysellads []\n"
+ "4.1 fa-cab (alias) []\n"
+ "4.2 fa-calculator []\n"
+ " fa-calendar []\n"
+ "4.4 fa-calendar-check-o []\n"
+ "4.4 fa-calendar-minus-o []\n"
+ " fa-calendar-o []\n"
+ "4.4 fa-calendar-plus-o []\n"
+ "4.4 fa-calendar-times-o []\n"
+ " fa-camera []\n"
+ " fa-camera-retro []\n"
+ "4.1 fa-car []\n"
+ " fa-caret-down []\n"
+ " fa-caret-left []\n"
+ " fa-caret-right []\n"
+ " fa-caret-square-o-down []\n"
+ "4.0 fa-caret-square-o-left []\n"
+ " fa-caret-square-o-right []\n"
+ " fa-caret-square-o-up []\n"
+ " fa-caret-up []\n"
+ "4.3 fa-cart-arrow-down []\n"
+ "4.3 fa-cart-plus []\n"
+ "4.2 fa-cc []\n"
+ "4.2 fa-cc-amex []\n"
+ "4.4 fa-cc-diners-club []\n"
+ "4.2 fa-cc-discover []\n"
+ "4.4 fa-cc-jcb []\n"
+ "4.2 fa-cc-mastercard []\n"
+ "4.2 fa-cc-paypal []\n"
+ "4.2 fa-cc-stripe []\n"
+ "4.2 fa-cc-visa []\n"
+ " fa-certificate []\n"
+ " fa-chain (alias) []\n"
+ " fa-chain-broken []\n"
+ " fa-check []\n"
+ " fa-check-circle []\n"
+ " fa-check-circle-o []\n"
+ " fa-check-square []\n"
+ " fa-check-square-o []\n"
+ " fa-chevron-circle-down []\n"
+ " fa-chevron-circle-left []\n"
+ " fa-chevron-circle-right []\n"
+ " fa-chevron-circle-up []\n"
+ " fa-chevron-down []\n"
+ " fa-chevron-left []\n"
+ " fa-chevron-right []\n"
+ " fa-chevron-up []\n"
+ "4.1 fa-child []\n"
+ "4.4 fa-chrome []\n"
+ " fa-circle []\n"
+ " fa-circle-o []\n"
+ "4.1 fa-circle-o-notch []\n"
+ "4.1 fa-circle-thin []\n"
+ " fa-clipboard []\n"
+ " fa-clock-o []\n"
+ "4.4 fa-clone []\n"
+ " fa-close (alias) []\n"
+ " fa-cloud []\n"
+ " fa-cloud-download []\n"
+ " fa-cloud-upload []\n"
+ " fa-cny (alias) []\n"
+ " fa-code []\n"
+ " fa-code-fork []\n"
+ "4.1 fa-codepen []\n"
+ "4.5 fa-codiepie []\n"
+ " fa-coffee []\n"
+ " fa-cog []\n"
+ " fa-cogs []\n"
+ " fa-columns []\n"
+ " fa-comment []\n"
+ " fa-comment-o []\n"
+ "4.4 fa-commenting []\n"
+ "4.4 fa-commenting-o []\n"
+ " fa-comments []\n"
+ " fa-comments-o []\n"
+ " fa-compass []\n"
+ " fa-compress []\n"
+ "4.3 fa-connectdevelop []\n"
+ "4.4 fa-contao []\n"
+ " fa-copy (alias) []\n"
+ "4.2 fa-copyright []\n"
+ "4.4 fa-creative-commons []\n"
+ " fa-credit-card []\n"
+ "4.5 fa-credit-card-alt []\n"
+ " fa-crop []\n"
+ " fa-crosshairs []\n"
+ " fa-css3 []\n"
+ "4.1 fa-cube []\n"
+ "4.1 fa-cubes []\n"
+ " fa-cut (alias) []\n"
+ " fa-cutlery []\n"
+ " fa-dashboard (alias) []\n"
+ "4.3 fa-dashcube []\n"
+ "4.1 fa-database []\n"
+ "4.6 fa-deaf []\n"
+ "4.6 fa-deafness (alias) []\n"
+ " fa-dedent (alias) []\n"
+ "4.1 fa-delicious []\n"
+ " fa-desktop []\n"
+ "4.1 fa-deviantart []\n"
+ "4.3 fa-diamond []\n"
+ "4.1 fa-digg []\n"
+ " fa-dollar (alias) []\n"
+ "4.0 fa-dot-circle-o []\n"
+ " fa-download []\n"
+ " fa-dribbble []\n"
+ " fa-dropbox []\n"
+ "4.1 fa-drupal []\n"
+ "4.5 fa-edge []\n"
+ " fa-edit (alias) []\n"
+ " fa-eject []\n"
+ " fa-ellipsis-h []\n"
+ " fa-ellipsis-v []\n"
+ "4.1 fa-empire []\n"
+ " fa-envelope []\n"
+ " fa-envelope-o []\n"
+ "4.1 fa-envelope-square []\n"
+ "4.6 fa-envira []\n"
+ " fa-eraser []\n"
+ " fa-eur []\n"
+ " fa-euro (alias) []\n"
+ " fa-exchange []\n"
+ " fa-exclamation []\n"
+ " fa-exclamation-circle []\n"
+ " fa-exclamation-triangle []\n"
+ " fa-expand []\n"
+ "4.4 fa-expeditedssl []\n"
+ " fa-external-link []\n"
+ " fa-external-link-square []\n"
+ " fa-eye []\n"
+ " fa-eye-slash []\n"
+ "4.2 fa-eyedropper []\n"
+ "4.6 fa-fa (alias) []\n"
+ " fa-facebook []\n"
+ " fa-facebook-f (alias) []\n"
+ "4.3 fa-facebook-official []\n"
+ " fa-facebook-square []\n"
+ " fa-fast-backward []\n"
+ " fa-fast-forward []\n"
+ "4.1 fa-fax []\n"
+ " fa-feed (alias) []\n"
+ " fa-female []\n"
+ " fa-fighter-jet []\n"
+ " fa-file []\n"
+ "4.1 fa-file-archive-o []\n"
+ "4.1 fa-file-audio-o []\n"
+ "4.1 fa-file-code-o []\n"
+ "4.1 fa-file-excel-o []\n"
+ "4.1 fa-file-image-o []\n"
+ "4.1 fa-file-movie-o (alias) []\n"
+ " fa-file-o []\n"
+ "4.1 fa-file-pdf-o []\n"
+ "4.1 fa-file-photo-o (alias) []\n"
+ "4.1 fa-file-picture-o (alias) []\n"
+ "4.1 fa-file-powerpoint-o []\n"
+ "4.1 fa-file-sound-o (alias) []\n"
+ " fa-file-text []\n"
+ " fa-file-text-o []\n"
+ "4.1 fa-file-video-o []\n"
+ "4.1 fa-file-word-o []\n"
+ "4.1 fa-file-zip-o (alias) []\n"
+ " fa-files-o []\n"
+ " fa-film []\n"
+ " fa-filter []\n"
+ " fa-fire []\n"
+ " fa-fire-extinguisher []\n"
+ "4.4 fa-firefox []\n"
+ "4.6 fa-first-order []\n"
+ " fa-flag []\n"
+ " fa-flag-checkered []\n"
+ " fa-flag-o []\n"
+ " fa-flash (alias) []\n"
+ " fa-flask []\n"
+ " fa-flickr []\n"
+ " fa-floppy-o []\n"
+ " fa-folder []\n"
+ " fa-folder-o []\n"
+ " fa-folder-open []\n"
+ " fa-folder-open-o []\n"
+ " fa-font []\n"
+ "4.6 fa-font-awesome []\n"
+ "4.4 fa-fonticons []\n"
+ "4.5 fa-fort-awesome []\n"
+ "4.3 fa-forumbee []\n"
+ " fa-forward []\n"
+ " fa-foursquare []\n"
+ " fa-frown-o []\n"
+ "4.2 fa-futbol-o []\n"
+ " fa-gamepad []\n"
+ " fa-gavel []\n"
+ " fa-gbp []\n"
+ "4.1 fa-ge (alias) []\n"
+ " fa-gear (alias) []\n"
+ " fa-gears (alias) []\n"
+ "4.4 fa-genderless []\n"
+ "4.4 fa-get-pocket []\n"
+ "4.4 fa-gg []\n"
+ "4.4 fa-gg-circle []\n"
+ " fa-gift []\n"
+ "4.1 fa-git []\n"
+ "4.1 fa-git-square []\n"
+ " fa-github []\n"
+ " fa-github-alt []\n"
+ " fa-github-square []\n"
+ "4.6 fa-gitlab []\n"
+ " fa-gittip (alias) []\n"
+ " fa-glass []\n"
+ "4.6 fa-glide []\n"
+ "4.6 fa-glide-g []\n"
+ " fa-globe []\n"
+ "4.1 fa-google []\n"
+ " fa-google-plus []\n"
+ "4.6 fa-google-plus-circle (alias) []\n"
+ "4.6 fa-google-plus-official []\n"
+ " fa-google-plus-square []\n"
+ "4.2 fa-google-wallet []\n"
+ "4.1 fa-graduation-cap []\n"
+ " fa-gratipay []\n"
+ " fa-group (alias) []\n"
+ " fa-h-square []\n"
+ "4.1 fa-hacker-news []\n"
+ "4.4 fa-hand-grab-o (alias) []\n"
+ "4.4 fa-hand-lizard-o []\n"
+ " fa-hand-o-down []\n"
+ " fa-hand-o-left []\n"
+ " fa-hand-o-right []\n"
+ " fa-hand-o-up []\n"
+ "4.4 fa-hand-paper-o []\n"
+ "4.4 fa-hand-peace-o []\n"
+ "4.4 fa-hand-pointer-o []\n"
+ "4.4 fa-hand-rock-o []\n"
+ "4.4 fa-hand-scissors-o []\n"
+ "4.4 fa-hand-spock-o []\n"
+ "4.4 fa-hand-stop-o (alias) []\n"
+ "4.6 fa-hard-of-hearing (alias) []\n"
+ "4.5 fa-hashtag []\n"
+ " fa-hdd-o []\n"
+ "4.1 fa-header []\n"
+ " fa-headphones []\n"
+ " fa-heart []\n"
+ " fa-heart-o []\n"
+ "4.3 fa-heartbeat []\n"
+ "4.1 fa-history []\n"
+ " fa-home []\n"
+ " fa-hospital-o []\n"
+ "4.3 fa-hotel (alias) []\n"
+ "4.4 fa-hourglass []\n"
+ "4.4 fa-hourglass-1 (alias) []\n"
+ "4.4 fa-hourglass-2 (alias) []\n"
+ "4.4 fa-hourglass-3 (alias) []\n"
+ "4.4 fa-hourglass-end []\n"
+ "4.4 fa-hourglass-half []\n"
+ "4.4 fa-hourglass-o []\n"
+ "4.4 fa-hourglass-start []\n"
+ "4.4 fa-houzz []\n"
+ " fa-html5 []\n"
+ "4.4 fa-i-cursor []\n"
+ "4.2 fa-ils []\n"
+ " fa-image (alias) []\n"
+ " fa-inbox []\n"
+ " fa-indent []\n"
+ "4.4 fa-industry []\n"
+ " fa-info []\n"
+ " fa-info-circle []\n"
+ " fa-inr []\n"
+ "4.6 fa-instagram []\n"
+ "4.1 fa-institution (alias) []\n"
+ "4.4 fa-internet-explorer []\n"
+ "4.3 fa-intersex (alias) []\n"
+ "4.2 fa-ioxhost []\n"
+ " fa-italic []\n"
+ "4.1 fa-joomla []\n"
+ " fa-jpy []\n"
+ "4.1 fa-jsfiddle []\n"
+ " fa-key []\n"
+ " fa-keyboard-o []\n"
+ " fa-krw []\n"
+ "4.1 fa-language []\n"
+ " fa-laptop []\n"
+ "4.2 fa-lastfm []\n"
+ "4.2 fa-lastfm-square []\n"
+ " fa-leaf []\n"
+ "4.3 fa-leanpub []\n"
+ " fa-legal (alias) []\n"
+ " fa-lemon-o []\n"
+ " fa-level-down []\n"
+ " fa-level-up []\n"
+ "4.1 fa-life-bouy (alias) []\n"
+ "4.1 fa-life-buoy (alias) []\n"
+ "4.1 fa-life-ring []\n"
+ "4.1 fa-life-saver (alias) []\n"
+ " fa-lightbulb-o []\n"
+ "4.2 fa-line-chart []\n"
+ " fa-link []\n"
+ " fa-linkedin []\n"
+ " fa-linkedin-square []\n"
+ " fa-linux []\n"
+ " fa-list []\n"
+ " fa-list-alt []\n"
+ " fa-list-ol []\n"
+ " fa-list-ul []\n"
+ " fa-location-arrow []\n"
+ " fa-lock []\n"
+ " fa-long-arrow-down []\n"
+ " fa-long-arrow-left []\n"
+ " fa-long-arrow-right []\n"
+ " fa-long-arrow-up []\n"
+ "4.6 fa-low-vision []\n"
+ " fa-magic []\n"
+ " fa-magnet []\n"
+ " fa-mail-forward (alias) []\n"
+ " fa-mail-reply (alias) []\n"
+ " fa-mail-reply-all (alias) []\n"
+ " fa-male []\n"
+ "4.4 fa-map []\n"
+ " fa-map-marker []\n"
+ "4.4 fa-map-o []\n"
+ "4.4 fa-map-pin []\n"
+ "4.4 fa-map-signs []\n"
+ "4.3 fa-mars []\n"
+ "4.3 fa-mars-double []\n"
+ "4.3 fa-mars-stroke []\n"
+ "4.3 fa-mars-stroke-h []\n"
+ "4.3 fa-mars-stroke-v []\n"
+ " fa-maxcdn []\n"
+ "4.2 fa-meanpath []\n"
+ "4.3 fa-medium []\n"
+ " fa-medkit []\n"
+ " fa-meh-o []\n"
+ "4.3 fa-mercury []\n"
+ " fa-microphone []\n"
+ " fa-microphone-slash []\n"
+ " fa-minus []\n"
+ " fa-minus-circle []\n"
+ " fa-minus-square []\n"
+ " fa-minus-square-o []\n"
+ "4.5 fa-mixcloud []\n"
+ " fa-mobile []\n"
+ " fa-mobile-phone (alias) []\n"
+ "4.5 fa-modx []\n"
+ " fa-money []\n"
+ " fa-moon-o []\n"
+ "4.1 fa-mortar-board (alias) []\n"
+ "4.3 fa-motorcycle []\n"
+ "4.4 fa-mouse-pointer []\n"
+ " fa-music []\n"
+ " fa-navicon (alias) []\n"
+ "4.3 fa-neuter []\n"
+ "4.2 fa-newspaper-o []\n"
+ "4.4 fa-object-group []\n"
+ "4.4 fa-object-ungroup []\n"
+ "4.4 fa-odnoklassniki []\n"
+ "4.4 fa-odnoklassniki-square []\n"
+ "4.4 fa-opencart []\n"
+ "4.1 fa-openid []\n"
+ "4.4 fa-opera []\n"
+ "4.4 fa-optin-monster []\n"
+ " fa-outdent []\n"
+ "4.0 fa-pagelines []\n"
+ "4.2 fa-paint-brush []\n"
+ "4.1 fa-paper-plane []\n"
+ "4.1 fa-paper-plane-o []\n"
+ " fa-paperclip []\n"
+ "4.1 fa-paragraph []\n"
+ " fa-paste (alias) []\n"
+ " fa-pause []\n"
+ "4.5 fa-pause-circle []\n"
+ "4.5 fa-pause-circle-o []\n"
+ "4.1 fa-paw []\n"
+ "4.2 fa-paypal []\n"
+ " fa-pencil []\n"
+ " fa-pencil-square []\n"
+ " fa-pencil-square-o []\n"
+ "4.5 fa-percent []\n"
+ " fa-phone []\n"
+ " fa-phone-square []\n"
+ " fa-photo (alias) []\n"
+ " fa-picture-o []\n"
+ "4.2 fa-pie-chart []\n"
+ "4.6 fa-pied-piper []\n"
+ "4.1 fa-pied-piper-alt []\n"
+ "4.1 fa-pied-piper-pp []\n"
+ " fa-pinterest []\n"
+ "4.3 fa-pinterest-p []\n"
+ " fa-pinterest-square []\n"
+ " fa-plane []\n"
+ " fa-play []\n"
+ " fa-play-circle []\n"
+ " fa-play-circle-o []\n"
+ "4.2 fa-plug []\n"
+ " fa-plus []\n"
+ " fa-plus-circle []\n"
+ " fa-plus-square []\n"
+ "4.0 fa-plus-square-o []\n"
+ " fa-power-off []\n"
+ " fa-print []\n"
+ "4.5 fa-product-hunt []\n"
+ " fa-puzzle-piece []\n"
+ "4.1 fa-qq []\n"
+ " fa-qrcode []\n"
+ " fa-question []\n"
+ " fa-question-circle []\n"
+ "4.6 fa-question-circle-o []\n"
+ " fa-quote-left []\n"
+ " fa-quote-right []\n"
+ "4.1 fa-ra (alias) []\n"
+ " fa-random []\n"
+ "4.1 fa-rebel []\n"
+ "4.1 fa-recycle []\n"
+ "4.1 fa-reddit []\n"
+ "4.5 fa-reddit-alien []\n"
+ "4.1 fa-reddit-square []\n"
+ " fa-refresh []\n"
+ "4.4 fa-registered []\n"
+ " fa-remove (alias) []\n"
+ " fa-renren []\n"
+ " fa-reorder (alias) []\n"
+ " fa-repeat []\n"
+ " fa-reply []\n"
+ " fa-reply-all []\n"
+ "4.1 fa-resistance (alias) []\n"
+ " fa-retweet []\n"
+ " fa-rmb (alias) []\n"
+ " fa-road []\n"
+ " fa-rocket []\n"
+ " fa-rotate-left (alias) []\n"
+ " fa-rotate-right (alias) []\n"
+ "4.0 fa-rouble (alias) []\n"
+ " fa-rss []\n"
+ " fa-rss-square []\n"
+ "4.0 fa-rub []\n"
+ "4.0 fa-ruble (alias) []\n"
+ " fa-rupee (alias) []\n"
+ "4.4 fa-safari []\n"
+ " fa-save (alias) []\n"
+ " fa-scissors []\n"
+ "4.5 fa-scribd []\n"
+ " fa-search []\n"
+ " fa-search-minus []\n"
+ " fa-search-plus []\n"
+ "4.3 fa-sellsy []\n"
+ "4.1 fa-send (alias) []\n"
+ "4.1 fa-send-o (alias) []\n"
+ "4.3 fa-server []\n"
+ " fa-share []\n"
+ "4.1 fa-share-alt []\n"
+ "4.1 fa-share-alt-square []\n"
+ " fa-share-square []\n"
+ " fa-share-square-o []\n"
+ "4.2 fa-shekel (alias) []\n"
+ "4.2 fa-sheqel (alias) []\n"
+ " fa-shield []\n"
+ "4.3 fa-ship []\n"
+ "4.3 fa-shirtsinbulk []\n"
+ "4.5 fa-shopping-bag []\n"
+ "4.5 fa-shopping-basket []\n"
+ " fa-shopping-cart []\n"
+ " fa-sign-in []\n"
+ "4.6 fa-sign-language []\n"
+ " fa-sign-out []\n"
+ " fa-signal []\n"
+ "4.6 fa-signing (alias) []\n"
+ "4.3 fa-simplybuilt []\n"
+ " fa-sitemap []\n"
+ "4.3 fa-skyatlas []\n"
+ " fa-skype []\n"
+ "4.1 fa-slack []\n"
+ "4.1 fa-sliders []\n"
+ "4.2 fa-slideshare []\n"
+ " fa-smile-o []\n"
+ "4.6 fa-snapchat []\n"
+ "4.6 fa-snapchat-ghost []\n"
+ "4.6 fa-snapchat-square []\n"
+ "4.2 fa-soccer-ball-o (alias) []\n"
+ " fa-sort []\n"
+ " fa-sort-alpha-asc []\n"
+ " fa-sort-alpha-desc []\n"
+ " fa-sort-amount-asc []\n"
+ " fa-sort-amount-desc []\n"
+ " fa-sort-asc []\n"
+ " fa-sort-desc []\n"
+ " fa-sort-down (alias) []\n"
+ " fa-sort-numeric-asc []\n"
+ " fa-sort-numeric-desc []\n"
+ " fa-sort-up (alias) []\n"
+ "4.1 fa-soundcloud []\n"
+ "4.1 fa-space-shuttle []\n"
+ " fa-spinner []\n"
+ "4.1 fa-spoon []\n"
+ "4.1 fa-spotify []\n"
+ " fa-square []\n"
+ " fa-square-o []\n"
+ "4.0 fa-stack-exchange []\n"
+ " fa-stack-overflow []\n"
+ " fa-star []\n"
+ " fa-star-half []\n"
+ " fa-star-half-empty (alias) []\n"
+ " fa-star-half-full (alias) []\n"
+ " fa-star-half-o []\n"
+ " fa-star-o []\n"
+ "4.1 fa-steam []\n"
+ "4.1 fa-steam-square []\n"
+ " fa-step-backward []\n"
+ " fa-step-forward []\n"
+ " fa-stethoscope []\n"
+ "4.4 fa-sticky-note []\n"
+ "4.4 fa-sticky-note-o []\n"
+ " fa-stop []\n"
+ "4.5 fa-stop-circle []\n"
+ "4.5 fa-stop-circle-o []\n"
+ "4.3 fa-street-view []\n"
+ " fa-strikethrough []\n"
+ "4.1 fa-stumbleupon []\n"
+ "4.1 fa-stumbleupon-circle []\n"
+ " fa-subscript []\n"
+ "4.3 fa-subway []\n"
+ " fa-suitcase []\n"
+ " fa-sun-o []\n"
+ " fa-superscript []\n"
+ "4.1 fa-support (alias) []\n"
+ " fa-table []\n"
+ " fa-tablet []\n"
+ " fa-tachometer []\n"
+ " fa-tag []\n"
+ " fa-tags []\n"
+ " fa-tasks []\n"
+ "4.1 fa-taxi []\n"
+ "4.4 fa-television []\n"
+ "4.1 fa-tencent-weibo []\n"
+ " fa-terminal []\n"
+ " fa-text-height []\n"
+ " fa-text-width []\n"
+ " fa-th []\n"
+ " fa-th-large []\n"
+ " fa-th-list []\n"
+ "4.6 fa-themeisle []\n"
+ " fa-thumb-tack []\n"
+ " fa-thumbs-down []\n"
+ " fa-thumbs-o-down []\n"
+ " fa-thumbs-o-up []\n"
+ " fa-thumbs-up []\n"
+ " fa-ticket []\n"
+ " fa-times []\n"
+ " fa-times-circle []\n"
+ " fa-times-circle-o []\n"
+ " fa-tint []\n"
+ " fa-toggle-down (alias) []\n"
+ "4.0 fa-toggle-left (alias) []\n"
+ "4.2 fa-toggle-off []\n"
+ "4.2 fa-toggle-on []\n"
+ " fa-toggle-right (alias) []\n"
+ " fa-toggle-up (alias) []\n"
+ "4.4 fa-trademark []\n"
+ "4.3 fa-train []\n"
+ "4.3 fa-transgender []\n"
+ "4.3 fa-transgender-alt []\n"
+ "4.2 fa-trash []\n"
+ " fa-trash-o []\n"
+ "4.1 fa-tree []\n"
+ " fa-trello []\n"
+ "4.4 fa-tripadvisor []\n"
+ " fa-trophy []\n"
+ " fa-truck []\n"
+ "4.0 fa-try []\n"
+ "4.2 fa-tty []\n"
+ " fa-tumblr []\n"
+ " fa-tumblr-square []\n"
+ "4.0 fa-turkish-lira (alias) []\n"
+ "4.4 fa-tv (alias) []\n"
+ "4.2 fa-twitch []\n"
+ " fa-twitter []\n"
+ " fa-twitter-square []\n"
+ " fa-umbrella []\n"
+ " fa-underline []\n"
+ " fa-undo []\n"
+ "4.6 fa-universal-access []\n"
+ "4.1 fa-university []\n"
+ " fa-unlink (alias) []\n"
+ " fa-unlock []\n"
+ " fa-unlock-alt []\n"
+ " fa-unsorted (alias) []\n"
+ " fa-upload []\n"
+ "4.5 fa-usb []\n"
+ " fa-usd []\n"
+ " fa-user []\n"
+ " fa-user-md []\n"
+ "4.3 fa-user-plus []\n"
+ "4.3 fa-user-secret []\n"
+ "4.3 fa-user-times []\n"
+ " fa-users []\n"
+ "4.3 fa-venus []\n"
+ "4.3 fa-venus-double []\n"
+ "4.3 fa-venus-mars []\n"
+ "4.3 fa-viacoin []\n"
+ "4.6 fa-viadeo []\n"
+ "4.6 fa-viadeo-square []\n"
+ " fa-video-camera []\n"
+ "4.4 fa-vimeo []\n"
+ "4.0 fa-vimeo-square []\n"
+ "4.1 fa-vine []\n"
+ " fa-vk []\n"
+ "4.6 fa-volume-control-phone []\n"
+ " fa-volume-down []\n"
+ " fa-volume-off []\n"
+ " fa-volume-up []\n"
+ " fa-warning (alias) []\n"
+ "4.1 fa-wechat (alias) []\n"
+ " fa-weibo []\n"
+ "4.1 fa-weixin []\n"
+ "4.3 fa-whatsapp []\n"
+ "4.0 fa-wheelchair []\n"
+ "4.6 fa-wheelchair-alt []\n"
+ "4.2 fa-wifi []\n"
+ "4.4 fa-wikipedia-w []\n"
+ " fa-windows []\n"
+ " fa-won (alias) []\n"
+ "4.1 fa-wordpress []\n"
+ "4.6 fa-wpbeginner []\n"
+ "4.6 fa-wpforms []\n"
+ " fa-wrench []\n"
+ " fa-xing []\n"
+ " fa-xing-square []\n"
+ "4.4 fa-y-combinator []\n"
+ "4.1 fa-y-combinator-square (alias) []\n"
+ "4.1 fa-yahoo []\n"
+ "4.4 fa-yc (alias) []\n"
+ "4.1 fa-yc-square (alias) []\n"
+ "4.2 fa-yelp []\n"
+ " fa-yen (alias) []\n"
+ "4.6 fa-yoast []\n"
+ " fa-youtube []\n"
+ " fa-youtube-play []\n"
+ " fa-youtube-square []\n";
final String subst = "\\2\\t\\3\\t\\1\\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}