package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(?|(.*)table$|(.*))$`)
var str = `diningtable
cookingtable
cooking
table
tabletable`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}