import Foundation
let pattern = #",[ ]?([0-9]+[.]?[0-9]+)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #" [1000, 12312.123123213, 1150370.5]"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}