re = /(?:\d+)(?:[\/.-](?:\d+)){1,2}/m
str = 'WC 12/10 change FC from 24 to 32
W/C 12/10 change fc from 401 to 340
W/C12/10 18 - 26
W?C 12/20/22 abc
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end