$re = '/(?i)(?:key|api|token|secret|client|passwd|password|auth|access)(?:[0-9a-z\-_\t .]{0,20})(?:[\s|\']|[\s|"]){0,3}(?:=|>|:=|\|\|:|<=|=>|:)(?:\'|\"|\s|=|\x60){0,5}([0-9a-z\-_.=]{10,150})(?:[\'|\"|\n|\r|\s|\x60|;]|$)/m';
$str = '# In[ ]:
response = qm.mysql_query(query="abc", database=\'abc\', host= \'example.com\', user=\'app_user\', passwd=\'ExposedExposedExposedExposed\')
print(response)';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);