$re = '/(?i)(?:key|api|token|secret|client|passwd|password|auth|access|sas)(?:[0-9a-z\-_\t .]{0,20})(?:[\s|\']|[\s|"]){0,3}(?:=|>|:=|\|\|:|<=|=>|:)(?:\'|\"|\s|=|\x60){0,5}([0-9a-z\-_.=]{10,150})(?:[\'|\"|\n|\r|\s|\x60|;]|$)/m';
$str = '# In[ ]:
response = qm.mysql_query(query="abc", database=\'abc\', host= \'example.com\', user=\'app_user\', sas_token = "sv=2022-11-04&ss=bqqt&srr=sco&sp=rlx&se=2025-05-15T20:23:12Z&st=2024-05-13T13:28:12Z&spr=https&sig=cPKp3mZiRDcJmVCajMT09Ql4ckD3OzGIRVDWzXepLVw%3D")
print(response)';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);