$re = '/.{5}(?!$)/m';
$str = '12345678909876543212';
$subst = "$0-";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;