# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"((?:INV)\+(?:[^+\n]*\+){4})\d{8}"
test_str = ("UNA:+,? '\n"
"UNB+UNOC:3+000000000+000000000+20190801:1115+00001+DDMP190001'\n"
"UNH+00001+BRKE:01+00+0'\n"
"INV+ED Format 1+Brustkrebs+19880117+E000000001+20080702+++1+0'\n"
"FAL+087897044+0000000++Trägername+000000000+0+20080702++1+++J+N+N+N+N+N+++0'\n"
"INL+181095200+385762115+++0'\n"
"BEE+20080702++++0'\n"
"BAA+++J+J++++++J+++++++J++0'\n"
"BBA++++++++J++++++J+J++++++J+++++J+++J+J++++++++J+0'\n"
"BHP+J+++++J+++++J+++++0'\n"
"BLA+++J+++++++++0'\n"
"BFA++++++++++++J++0'\n"
"BSA++J+++J+J+++0'\n"
"BAT+20190801+0'\n"
"DAT+20080702++++0'\n"
"UNT+000014+00001'\n"
"UNZ+00001+00001'\n\n")
subst = "\\g<1>20200101"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.