# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"([^\r\n\t\f>< /]+(?!>))\b"
test_str = ("<p><h1>PREMIER CHAPITRE</p>\n"
"<p>Lorsque j'avais <u>six</u> ans j'ai vu, une fois, une magnifique image, dans un livre sur la Forêt Vierge qui s'appelait \"Histoires Vécues\". Ça représentait un serpent boa qui avalait un fauve. Voilà la copie du dessin.<br />\n"
"</p>\n\n"
"<div class=\"vvvv\">no comment</div>\n\n"
"<p>On disait dans le livre: \"Les serpents boas avalent leur proie tout entière, sans la mâcher. Ensuite ils ne peuvent plus bouger et ils dorment pendant les six mois de leur digestion\".</p>\n\n"
"<p>J'ai alors beaucoup réfléchi sur les aventures de la jungle et, à mon tour, j'ai réussi, avec un crayon de couleur, à tracer mon premier dessin. Mon dessin numéro 1. Il était comme ça:</p>\n\n"
"<p>J'ai montré mon chef d'oeuvre aux grandes personnes et je leur ai demandé si mon dessin leur faisait peur.</p>\n\n"
"<p>Sur ta chevelure profonde<br />\n"
"Aux âcres parfums,<br />\n"
"Mer odorante et vagabonde<br />\n"
"Aux flots bleus et bruns,</p>\n\n"
"<p>Comme un navire qui s'éveille<br />\n"
"Au vent du matin,<br />\n"
"Mon âme rêveuse appareille<br />\n"
"Pour un ciel lointain.</p>\n\n"
"<p>Tes yeux, où rien ne se révèle<br />\n"
"De doux ni d'amer,<br />\n"
"Sont deux bijoux froids où se mêle<br />\n"
"L'or avec le fer.</p>")
matches = re.finditer(regex, test_str)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.