using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<[^>]+>(*SKIP)(*FAIL)|([A-zÀ-ÿ]+)";
string input = @"Non ! Non ! Je ne veux pas d'un éléphant dans un boa.<br>
<p> Un boa c'est très dangereux, et un éléphant élévé c'est très encombrant. Chez moi c'est tout petit. J'ai besoin d'un mouton. Dessine-moi un mouton.
</p>";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}