$re = '/([\S|<([^>]+)>]+)/';
$str = 'Non ! Non ! Je ne veux pas d\'un éléphant!<br> dans un boa. Un boa c\'est très dangereux, et un éléphant c\'est très encombrant. Chez moi c\'est tout petit. J\'ai besoin d\'un mouton. Dessine-moi un mouton.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);