#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\.populate_tasks\[(arc|buck|build|hg|phabricator|source_control),"
Local $sString = "── infrastructure.devspeed.error_rates.devspeed_raw_cost_events.populate_tasks[arc,diff]" & @CRLF & _
"── infrastructure.devspeed.error_rates.devspeed_raw_cost_events.populate_tasks[arc,fix]" & @CRLF & _
"── infrastructure.devspeed.error_rates.devspeed_raw_cost_events.populate_tasks[arc,focus]" & @CRLF & _
"── infrastructure.devspeed.error_rates.devspeed_raw_cost_events.populate_tasks[arc,lint]" & @CRLF & _
"── infrastructure.devspeed.error_rates.devspeed_raw_cost_events.populate_tasks[arc,pull]" & @CRLF & _
"── infrastructure.devspeed.error_rates.devspeed_raw_cost_events.populate_tasks[arc,refocus]" & @CRLF & _
"── infrastructure.devspeed.error_rates.devspeed_raw_cost_events.populate_tasks[buck,build]" & @CRLF & _
"── infrastructure.devspeed.error_rates.devspeed_raw_cost_events.populate_tasks[buck,install]" & @CRLF & _
"── infrastructure.devspeed.error_rates.devspeed_raw_cost_events.populate_tasks[buck,project]" & @CRLF & _
"── infrastructure.devspeed.error_rates.devspeed_raw_cost_events.populate_tasks[buck,run]" & @CRLF & _
"── infrastructure.devspeed.error_rates.devspeed_raw_cost_events.populate_tasks[buck,test]" & @CRLF & _
"── infrastructure.devspeed.error_rates.devspeed_raw_cost_events.populate_tasks[build,arc_rebuild]" & @CRLF & _
"── infrastructure.devspeed.error_rates.devspeed_raw_cost_events.populate_tasks[build,buck_build]" & @CRLF & _
"── infrastructure.devspeed.error_rates.devspeed_raw_cost_events.populate_tasks[build,entschema]" & @CRLF & _
"── infrastructure.devspeed.error_rates.devspeed_raw_cost_events.populate_tasks[build,fbios_noextensions]" & @CRLF & _
"── infrastructure.devspeed.error_rates.devspeed_raw_cost_events.populate_tasks[build,instagram_ios_noextensions]" & @CRLF & _
"── infrastructure.devspeed.error_rates.devspeed_raw_cost_events.populate_tasks[build,messenger_ios_noextensions]" & @CRLF & _
"── infrastructure.devspeed.error_rates.devspeed_raw_cost_events.populate_tasks[build,multifeed]" & @CRLF & _
"── infrastructure.devspeed.error_rates.devspeed_raw_cost_events.populate_tasks[build,unicorn]" & @CRLF & _
"── infrastructure.devspeed.error_rates.devspeed_raw_cost_events.populate_tasks[build,wakizashi]" & @CRLF & _
"── infrastructure.devspeed.error_rates.devspeed_raw_cost_events.populate_tasks[build,wakizashi_s2p]" & @CRLF & _
"── infrastructure.devspeed.error_rates.devspeed_raw_cost_events.populate_tasks[devserver,arc_fix]" & @CRLF & _
"── infrastructure.devspeed.error_rates.devspeed_raw_cost_events.populate_tasks[devserver,fixmyserver]" & @CRLF & _
"── infrastructure.devspeed.error_rates.devspeed_raw_cost_events.populate_tasks[devserver,flow_oom]" & @CRLF & _
"── infrastructure.devspeed.error_rates.devspeed_raw_cost_events.populate_tasks[devserver,hack_oom]" & @CRLF & _
"── infrastructure.devspeed.error_rates.devspeed_raw_cost_events.populate_tasks[devserver,hhserver_oom]" & @CRLF & _
"── infrastructure.devspeed.error_rates.devspeed_raw_cost_events.populate_tasks[hack,hh_healthy_minutes]" & @CRLF & _
"── infrastructure.devspeed.error_rates.devspeed_raw_cost_events.populate_tasks[hg,amend]" & @CRLF & _
"── infrastructure.devspeed.error_rates.devspeed_raw_cost_events.populate_tasks[hg,bookmarks]" & @CRLF & _
"── infrastructure.devspeed.error_rates.devspeed_raw_cost_events.populate_tasks[hg,branch]" & @CRLF & _
"── infrastructure.devspeed.error_rates.devspeed_raw_cost_events.populate_tasks[hg,commit]" & @CRLF & _
"── infrastructure.devspeed.error_rates.devspeed_raw_cost_events.populate_tasks[hg,diff]" & @CRLF & _
"── infrastructure.devspeed.error_rates.devspeed_raw_cost_events.populate_tasks[hg,log]" & @CRLF & _
"── infrastructure.devspeed.error_rates.devspeed_raw_cost_events.populate_tasks[hg,pull]" & @CRLF & _
"── infrastructure.devspeed.error_rates.devspeed_raw_cost_events.populate_tasks[hg,rebase]" & @CRLF & _
"── infrastructure.devspeed.error_rates.devspeed_raw_cost_events.populate_tasks[hg,smartlog]" & @CRLF & _
"── infrastructure.devspeed.error_rates.devspeed_raw_cost_events.populate_tasks[hg,status]" & @CRLF & _
"── infrastructure.devspeed.error_rates.devspeed_raw_cost_events.populate_tasks[hg,update]" & @CRLF & _
"── infrastructure.devspeed.error_rates.devspeed_raw_cost_events.populate_tasks[ide,flow_check]" & @CRLF & _
"── infrastructure.devspeed.error_rates.devspeed_raw_cost_events.populate_tasks[ide,flow_init]" & @CRLF & _
"── infrastructure.devspeed.error_rates.devspeed_raw_cost_events.populate_tasks[ide,hh_full_check]" & @CRLF & _
"── infrastructure.devspeed.error_rates.devspeed_raw_cost_events.populate_tasks[ide,hh_lazy_check]" & @CRLF & _
"── infrastructure.devspeed.error_rates.devspeed_raw_cost_events.populate_tasks[ide,hh_server_init]" & @CRLF & _
"── infrastructure.devspeed.error_rates.devspeed_raw_cost_events.populate_tasks[ide,intellij_file_to_intellisense]" & @CRLF & _
"── infrastructure.devspeed.error_rates.devspeed_raw_cost_events.populate_tasks[ide,intellij_project_to_intellisense]" & @CRLF & _
"── infrastructure.devspeed.error_rates.devspeed_raw_cost_events.populate_tasks[land,clean_lands]" & @CRLF & _
"── infrastructure.devspeed.error_rates.devspeed_raw_cost_events.populate_tasks[land,landcastle]" & @CRLF & _
"── infrastructure.devspeed.error_rates.devspeed_raw_cost_events.populate_tasks[phabricator,diffusion_pageload]" & @CRLF & _
"── infrastructure.devspeed.error_rates.devspeed_raw_cost_events.populate_tasks[phabricator,gql_client_duration]" & @CRLF & _
"── infrastructure.devspeed.error_rates.devspeed_raw_cost_events.populate_tasks[phabricator,gql_mutation_duration]" & @CRLF & _
"── infrastructure.devspeed.error_rates.devspeed_raw_cost_events.populate_tasks[phabricator,jf_submit_set_dependencies]" & @CRLF & _
"── infrastructure.devspeed.error_rates.devspeed_raw_cost_events.populate_tasks[phabricator,jf_submit_set_diffproperty]" & @CRLF & _
"── infrastructure.devspeed.error_rates.devspeed_raw_cost_events.populate_tasks[phabricator,jf_submit_total_elapsed]" & @CRLF & _
"── infrastructure.devspeed.error_rates.devspeed_raw_cost_events.populate_tasks[phabricator,jf_submit_update_diff]" & @CRLF & _
"── infrastructure.devspeed.error_rates.devspeed_raw_cost_events.populate_tasks[phabricator,jf_submit_update_revision]" & @CRLF & _
"── infrastructure.devspeed.error_rates.devspeed_raw_cost_events.populate_tasks[presto,adhoc_queue]" & @CRLF & _
"── infrastructure.devspeed.error_rates.devspeed_raw_cost_events.populate_tasks[source_control,hg]" & @CRLF & _
"── infrastructure.devspeed.error_rates.devspeed_raw_cost_events.populate_tasks[source_control,jellyfish]" & @CRLF & _
"── infrastructure.devspeed.error_rates.devspeed_raw_cost_events.populate_tasks[test,local_www]" & @CRLF & _
"── infrastructure.devspeed.error_rates.devspeed_raw_cost_events.populate_tasks[test,mobilelab]"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")