$re = '/(?<!\S)\b(?:[A-Ga-g](?:b|#|m|mi|min|M|maj|bm|#m|#mi|bmi|bmin|#min|sus|dim|[1-9]+)+)+\b(?!=\S)/m';
$str = '808—Bass Loop Dm 147bpm.wav
Drifting 100bpm F7 18.aif
120bpm Awakened Fdim.mp3
Rhodes 90bpm Am7sus4.ogg
01 Awakened 120bpm C#M9Gm9.caf
this is a bad song.wav';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);