// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^\s?\d*\x1b.*?\\").unwrap();
let string = "*PotPlayerPlayListItem* F:\\赵剑宇\\C# 2014Net基础班(赵剑宇)零基础入门 (P1. 1、一些基本的概念).mp4
3527234 0 F:\\赵剑宇\\C# 2014Net基础班(赵剑宇)零基础入门 (P2. 2、VS的各个组成部分以及两行常用代码).mp4
0 0 F:\\赵剑宇\\C# 2014Net基础班(赵剑宇)零基础入门 (P3. 3、VS的一些设置).mp4
0 0 F:\\赵剑宇\\C# 2014Net基础班(赵剑宇)零基础入门 (P4. 4、VS中常用的快捷键).mp4
0 0 F:\\赵剑宇\\C# 2014Net基础班(赵剑宇)零基础入门 (P5. 5、注释符的使用).mp4
0 0 F:\\赵剑宇\\C# 2014Net基础班(赵剑宇)零基础入门 (P6. 6、小结).mp4
0 0 F:\\赵剑宇\\C# 2014Net基础班(赵剑宇)零基础入门 (P7. 7、变量练习).mp4
0 0 F:\\赵剑宇\\C# 2014Net基础班(赵剑宇)零基础入门 (P8. 8、变量的命名规范).mp4
0 0 F:\\赵剑宇\\C# 2014Net基础班(赵剑宇)零基础入门 (P9. 9、赋值运算符和+号的用法).mp4
0 0 F:\\赵剑宇\\C# 2014Net基础班(赵剑宇)零基础入门 (P10. 10、两个练习).mp4
0 0 F:\\赵剑宇\\C# 2014Net基础班(赵剑宇)零基础入门 (P11. 11、占位符的使用).mp4
0 0 F:\\赵剑宇\\C# 2014Net基础班(赵剑宇)零基础入门 (P12. 12、上午最后的练习).mp4
0 0 F:\\赵剑宇\\C# 2014Net基础班(赵剑宇)零基础入门 (P13. 13、接收用户的输入).mp4
485334 0 F:\\赵剑宇\\C# 2014Net基础班(赵剑宇)零基础入门 (P14. 14、转义符和@符号的用法).mp4
1833234 1 F:\\赵剑宇\\C# 2014Net基础班(赵剑宇)零基础入门 (P15. 15、算数运算符).mp4
563334 1 F:\\赵剑宇\\C# 2014Net基础班(赵剑宇)零基础入门 (P16. 16、自动类型转换和强制类型转换).mp4
1311900 1 F:\\赵剑宇\\C# 2014Net基础班(赵剑宇)零基础入门 (P17. 17、Convert类型转换).mp4
554074 1 F:\\赵剑宇\\C# 2014Net基础班(赵剑宇)零基础入门 (P18. 18、Convert的练习).mp4
657700 1 F:\\赵剑宇\\C# 2014Net基础班(赵剑宇)零基础入门 (P19. 19计算时间的练习题).mp4
686634 1 F:\\赵剑宇\\C# 2014Net基础班(赵剑宇)零基础入门 (P20. 20小结).mp4
478185 1 F:\\赵剑宇\\C# 2014Net基础班(赵剑宇)零基础入门 (P21. 21、复习).mp4
412103 1 F:\\赵剑宇\\C# 2014Net基础班(赵剑宇)零基础入门 (P22. 22、交换变量).mp4
670201 1 F:\\赵剑宇\\C# 2014Net基础班(赵剑宇)零基础入门 (P23. 23、加加减减和复合赋值运算符).mp4
1474334 1 F:\\赵剑宇\\C# 2014Net基础班(赵剑宇)零基础入门 (P24. 24、关系运算符和逻辑与运算符).mp4
1256134 1 F:\\赵剑宇\\C# 2014Net基础班(赵剑宇)零基础入门 (P25. 25、判断闰年练习).mp4
476800 1 F:\\赵剑宇\\C# 2014Net基础班(赵剑宇)零基础入门 (P26. 26、if-else结构).mp4
1047313 1 F:\\赵剑宇\\C# 2014Net基础班(赵剑宇)零基础入门 (P27. 27、分支结构之if结构).mp4
660868 1 F:\\赵剑宇\\C# 2014Net基础班(赵剑宇)零基础入门 (P28. 28、if else-if结构).mp4
1755100 1 F:\\赵剑宇\\C# 2014Net基础班(赵剑宇)零基础入门 (P29. 29、比较三个数字中的最大值).mp4
305901 1 F:\\赵剑宇\\C# 2014Net基础班(赵剑宇)零基础入门 (P30. 30、try-catch异常捕获).mp4
1344900 1 F:\\赵剑宇\\C# 2014Net基础班(赵剑宇)零基础入门 (P31. 31、三个练习).mp4
805201 1 F:\\赵剑宇\\C# 2014Net基础班(赵剑宇)零基础入门 (P32. 32、switch-case).mp4
1422083 1 F:\\赵剑宇\\C# 2014Net基础班(赵剑宇)零基础入门 (P33. 33、小结).mp4
394689 1 F:\\赵剑宇\\C# 2014Net基础班(赵剑宇)零基础入门 (P34. 34、复习).mp4
389584 1 F:\\赵剑宇\\C# 2014Net基础班(赵剑宇)零基础入门 (P35. 35、switch-case练习).mp4
803668 1 F:\\赵剑宇\\C# 2014Net基础班(赵剑宇)零基础入门 (P36. 36、判断闰年).mp4
849300 1 F:\\赵剑宇\\C# 2014Net基础班(赵剑宇)零基础入门 (P37. 37、while循环).mp4
966234 1 F:\\赵剑宇\\C# 2014Net基础班(赵剑宇)零基础入门 (P38. 38、while循环练习).mp4
277800 1 F:\\赵剑宇\\C# 2014Net基础班(赵剑宇)零基础入门 (P39. 39、while循环练习).mp4
602047 1 F:\\赵剑宇\\C# 2014Net基础班(赵剑宇)零基础入门 (P40. 40、while循环的3个练习).mp4
1224200 1 F:\\赵剑宇\\C# 2014Net基础班(赵剑宇)零基础入门 (P41. 41、break的用法).mp4
536134 1 F:\\赵剑宇\\C# 2014Net基础班(赵剑宇)零基础入门 (P42. 42、while循环练习结束).mp4
927591 1 F:\\赵剑宇\\C# 2014Net基础班(赵剑宇)零基础入门 (P43. 43、do-while循环).mp4
588068 1 F:\\赵剑宇\\C# 2014Net基础班(赵剑宇)零基础入门 (P44. 44、do-while循环的几个练习).mp4
1411900 1 F:\\赵剑宇\\C# 2014Net基础班(赵剑宇)零基础入门 (P45. 45、小复习).mp4
402587 0 F:\\赵剑宇\\C# 2014Net基础班(赵剑宇)零基础入门 (P46. 46、程序调试).mp4
0 0 F:\\赵剑宇\\C# 2014Net基础班(赵剑宇)零基础入门 (P47. 47、for循环语法).mp4
0 0 F:\\赵剑宇\\C# 2014Net基础班(赵剑宇)零基础入门 (P48. 48、for循环的正序和倒序输出).mp4
0 0 F:\\赵剑宇\\C# 2014Net基础班(赵剑宇)零基础入门 (P49. 49、乘法口诀表).mp4
0 0 F:\\赵剑宇\\C# 2014Net基础班(赵剑宇)零基础入门 (P50. 50、乘法口诀表(2)).mp4
0 0 F:\\赵剑宇\\C# 2014Net基础班(赵剑宇)零基础入门 (P51. 51、类型转换).mp4
1141600 0 F:\\赵剑宇\\C# 2014Net基础班(赵剑宇)零基础入门 (P52. 52、循环的3个练习).mp4
909700 1 F:\\赵剑宇\\C# 2014Net基础班(赵剑宇)零基础入门 (P53. 53、continue的用法).mp4
796600 0 F:\\赵剑宇\\C# 2014Net基础班(赵剑宇)零基础入门 (P54. 54、计算质数).mp4
484401 0 F:\\赵剑宇\\C# 2014Net基础班(赵剑宇)零基础入门 (P55. 55、三元表达式和随机数).mp4
1185600 0 F:\\赵剑宇\\C# 2014Net基础班(赵剑宇)零基础入门 (P56. 56、枚举类型).mp4
1106059 0 F:\\赵剑宇\\C# 2014Net基础班(赵剑宇)零基础入门 (P57. 57、枚举类型和int、string之间的转换).mp4
1420968 1 F:\\赵剑宇\\C# 2014Net基础班(赵剑宇)零基础入门 (P58. 58、结构).mp4
916434 1 F:\\赵剑宇\\C# 2014Net基础班(赵剑宇)零基础入门 (P59. 59、小总结).mp4
769555 1 F:\\赵剑宇\\C# 2014Net基础班(赵剑宇)零基础入门 (P60. 60、数组的基本概念).mp4
944600 1 F:\\赵剑宇\\C# 2014Net基础班(赵剑宇)零基础入门 (P61. 61、声明数组的4种方式).mp4
262634 1 F:\\赵剑宇\\C# 2014Net基础班(赵剑宇)零基础入门 (P62. 62、复习wmv).mp4
486834 1 F:\\赵剑宇\\C# 2014Net基础班(赵剑宇)零基础入门 (P63. 63、数组复习).mp4
271580 1 F:\\赵剑宇\\C# 2014Net基础班(赵剑宇)零基础入门 (P64. 64、数组的5个练习).mp4
1934094 1 F:\\赵剑宇\\C# 2014Net基础班(赵剑宇)零基础入门 (P65. 65、冒泡排序).mp4
1407101 1 F:\\赵剑宇\\C# 2014Net基础班(赵剑宇)零基础入门 (P66. 66、方法的语法).mp4
2225800 1 F:\\赵剑宇\\C# 2014Net基础班(赵剑宇)零基础入门 (P67. 67、调用者和被调用者).mp4
1532701 1 F:\\赵剑宇\\C# 2014Net基础班(赵剑宇)零基础入门 (P68. 68、方法练习).mp4
1035101 1 F:\\赵剑宇\\C# 2014Net基础班(赵剑宇)零基础入门 (P69. 8、out参数).mp4
1462301 1 F:\\赵剑宇\\C# 2014Net基础班(赵剑宇)零基础入门 (P70. 69、自动动手写TryParse).mp4
1096901 1 F:\\赵剑宇\\C# 2014Net基础班(赵剑宇)零基础入门 (P71. 70、小结).mp4
189056 1 F:\\赵剑宇\\C# 2014Net基础班(赵剑宇)零基础入门 (P72. 71、ref参数).mp4
842334 1 F:\\赵剑宇\\C# 2014Net基础班(赵剑宇)零基础入门 (P73. 72、方法的重载).mp4
813600 1 F:\\赵剑宇\\C# 2014Net基础班(赵剑宇)零基础入门 (P74. 73、params可变参数数组).mp4
708400 1 F:\\赵剑宇\\C# 2014Net基础班(赵剑宇)零基础入门 (P75. 74、方法的递归).mp4
855900 1 F:\\赵剑宇\\C# 2014Net基础班(赵剑宇)零基础入门 (P76. 75、方法结束).mp4
444100 1 F:\\赵剑宇\\C# 2014Net基础班(赵剑宇)零基础入门 (P77. 76、方法的练习).mp4
962571 1 F:\\赵剑宇\\C# 2014Net基础班(赵剑宇)零基础入门 (P78. 77、上午结束).mp4
841168 1 F:\\赵剑宇\\C# 2014Net基础班(赵剑宇)零基础入门 (P79. 78、方法的最后6个练习).mp4
1523634 1 F:\\赵剑宇\\C# 2014Net基础班(赵剑宇)零基础入门 (P80. 79、小复习).mp4
1869075 1 F:\\赵剑宇\\C# 2014Net基础班(赵剑宇)零基础入门 (P81. 80、画游戏头).mp4
586118 1 F:\\赵剑宇\\C# 2014Net基础班(赵剑宇)零基础入门 (P82. 81、初始化地图).mp4
1039300 1 F:\\赵剑宇\\C# 2014Net基础班(赵剑宇)零基础入门 (P83. 82、确定玩家A跟玩家B的坐标).mp4
834900 1 F:\\赵剑宇\\C# 2014Net基础班(赵剑宇)零基础入门 (P84. 83、画第一行的关卡).mp4
337800 1 F:\\赵剑宇\\C# 2014Net基础班(赵剑宇)零基础入门 (P85. 84、画第一竖行).mp4
568400 1 F:\\赵剑宇\\C# 2014Net基础班(赵剑宇)零基础入门 (P86. 85、画地图结束).mp4
227194 1 F:\\赵剑宇\\C# 2014Net基础班(赵剑宇)零基础入门 (P87. 86、输入玩家姓名).mp4
361070 1 F:\\赵剑宇\\C# 2014Net基础班(赵剑宇)零基础入门 (P88. 87、上午内容结束).mp4
291559 1 F:\\赵剑宇\\C# 2014Net基础班(赵剑宇)零基础入门 (P89. 88、开始玩游戏啦(1)).mp4
567101 1 F:\\赵剑宇\\C# 2014Net基础班(赵剑宇)零基础入门 (P90. 89、开始玩游戏啦(2)).mp4
960168 1 F:\\赵剑宇\\C# 2014Net基础班(赵剑宇)零基础入门 (P91. 90、飞行棋游戏结束).mp4
1466572 1 F:\\赵剑宇\\C# 2014Net基础班(赵剑宇)零基础入门 (P92. 91、面向对象简介).mp4
2747068 1 F:\\赵剑宇\\C# 2014Net基础班(赵剑宇)零基础入门 (P93. 92、类的实例化、字段、方法).mp4
1433553 1 F:\\赵剑宇\\C# 2014Net基础班(赵剑宇)零基础入门 (P94. 93、属性的介绍).mp4
705700 0 F:\\赵剑宇\\C# 2014Net基础班(赵剑宇)零基础入门 (P95. 94、属性的作用).mp4
715593 1 F:\\赵剑宇\\C# 2014Net基础班(赵剑宇)零基础入门 (P96. 95、面向对象练习).mp4
688801 1 F:\\赵剑宇\\C# 2014Net基础班(赵剑宇)零基础入门 (P97. 96、构造函数).mp4
1215564 1 F:\\赵剑宇\\C# 2014Net基础班(赵剑宇)零基础入门 (P98. 97、值类型和引用类型简介).mp4
541071 1 F:\\赵剑宇\\C# 2014Net基础班(赵剑宇)零基础入门 (P99. 98、上午总结).mp4
435100 1 F:\\赵剑宇\\C# 2014Net基础班(赵剑宇)零基础入门 (P100. 99、静态类和非静态类的区别).mp4
1482700 1 F:\\赵剑宇\\C# 2014Net基础班(赵剑宇)零基础入门 (P101. 100、垃圾回收期和析构函数).mp4
494634 1 F:\\赵剑宇\\C# 2014Net基础班(赵剑宇)零基础入门 (P102. 101、车票练习).mp4
455575 1 F:\\赵剑宇\\C# 2014Net基础班(赵剑宇)零基础入门 (P103. 102、不同项目之间的类的引用).mp4
413800 1 F:\\赵剑宇\\C# 2014Net基础班(赵剑宇)零基础入门 (P104. 103、字符串到字符数组的转换以及高效的StringBuilder).mp4
973067 1 F:\\赵剑宇\\C# 2014Net基础班(赵剑宇)零基础入门 (P105. 104、字符串的一些方法).mp4
1724900 1 F:\\赵剑宇\\C# 2014Net基础班(赵剑宇)零基础入门 (P106. 105、总结).mp4
303577 1 F:\\赵剑宇\\C# 2014Net基础班(赵剑宇)零基础入门 (P107. 106、字符串的方法).mp4
2063901 1 F:\\赵剑宇\\C# 2014Net基础班(赵剑宇)零基础入门 (P108. 107、字符串练习).mp4
1527601 0 F:\\赵剑宇\\C# 2014Net基础班(赵剑宇)零基础入门 (P109. 109、字符串结束).mp4
0 0 F:\\赵剑宇\\C# 2014Net基础班(赵剑宇)零基础入门 (P110. 110、继承开头。).mp4
0 0 F:\\赵剑宇\\C# 2014Net基础班(赵剑宇)零基础入门 (P111. 111、继承).mp4
0 0 F:\\赵剑宇\\C# 2014Net基础班(赵剑宇)零基础入门 (P112. 112、new的用法).mp4
0 0 F:\\赵剑宇\\C# 2014Net基础班(赵剑宇)零基础入门 (P113. 113、this的用法).mp4
0 0 F:\\赵剑宇\\C# 2014Net基础班(赵剑宇)零基础入门 (P114. 114、里氏转换以及as和is的用法).mp4
0 0 F:\\赵剑宇\\C# 2014Net基础班(赵剑宇)零基础入门 (P115. 115、里氏转换练习).mp4
0 0 F:\\赵剑宇\\C# 2014Net基础班(赵剑宇)零基础入门 (P116. 116、File类的基本操作).mp4
0 0 F:\\赵剑宇\\C# 2014Net基础班(赵剑宇)零基础入门 (P117. 117、总结).mp4
0 0 F:\\赵剑宇\\C# 2014Net基础班(赵剑宇)零基础入门 (P118. 118、复习).mp4
0 0 F:\\赵剑宇\\C# 2014Net基础班(赵剑宇)零基础入门 (P119. 119、ArrayList集合的常用方法).mp4
0 0 F:\\赵剑宇\\C# 2014Net基础班(赵剑宇)零基础入门 (P120. 120、wmv).mp4
0 0 F:\\赵剑宇\\C# 2014Net基础班(赵剑宇)零基础入门 (P121. 121、ArrayList集合的两个练习).mp4
0 0 F:\\赵剑宇\\C# 2014Net基础班(赵剑宇)零基础入门 (P122. 122、集合的长度问题).mp4
0 0 F:\\赵剑宇\\C# 2014Net基础班(赵剑宇)零基础入门 (P123. 123、ArrayList集合总结).mp4
0 0 F:\\赵剑宇\\C# 2014Net基础班(赵剑宇)零基础入门 (P124. 124、Hashtable集合).mp4
0 0 F:\\赵剑宇\\C# 2014Net基础班(赵剑宇)零基础入门 (P125. 125、简繁转换).mp4
0 0 F:\\赵剑宇\\C# 2014Net基础班(赵剑宇)零基础入门 (P126. 126、编码和File类读取文件).mp4
0 0 F:\\赵剑宇\\C# 2014Net基础班(赵剑宇)零基础入门 (P127. 127、使用File类写入数据).mp4
0 0 F:\\赵剑宇\\C# 2014Net基础班(赵剑宇)零基础入门 (P128. 128、Direcotry的操作).mp4
0 0 F:\\赵剑宇\\C# 2014Net基础班(赵剑宇)零基础入门 (P129. 129、Path类的操作).mp4
0 0 F:\\赵剑宇\\C# 2014Net基础班(赵剑宇)零基础入门 (P130. 130、总结).mp4
0 0 F:\\赵剑宇\\C# 2014Net基础班(赵剑宇)零基础入门 (P131. 131小复习).mp4
0 0 F:\\赵剑宇\\C# 2014Net基础班(赵剑宇)零基础入门 (P132. 132、FileStream的读写文件).mp4
0 0 F:\\赵剑宇\\C# 2014Net基础班(赵剑宇)零基础入门 (P133. 133、使用FileStream来对大文件进行复制).mp4
0 0 F:\\赵剑宇\\C# 2014Net基础班(赵剑宇)零基础入门 (P134. 134、StreamWriter和StreamReader).mp4
0 0 F:\\赵剑宇\\C# 2014Net基础班(赵剑宇)零基础入门 (P135. 135、装箱和拆箱).mp4
0 0 F:\\赵剑宇\\C# 2014Net基础班(赵剑宇)零基础入门 (P136. 136、泛型集合).mp4
0 0 F:\\赵剑宇\\C# 2014Net基础班(赵剑宇)零基础入门 (P137. 137、泛型集合的3个练习前奏).mp4
0 0 F:\\赵剑宇\\C# 2014Net基础班(赵剑宇)零基础入门 (P138. 138、泛型集合的3个练习).mp4
0 0 F:\\赵剑宇\\C# 2014Net基础班(赵剑宇)零基础入门 (P139. 140、抽象类练习).mp4
0 0 F:\\赵剑宇\\C# 2014Net基础班(赵剑宇)零基础入门 (P140. 141、总结).mp4
0 0 F:\\赵剑宇\\C# 2014Net基础班(赵剑宇)零基础入门 (P141. 142,模拟U盘、移动硬盘、MP3和电脑).mp4
0 0 F:\\赵剑宇\\C# 2014Net基础班(赵剑宇)零基础入门 (P142. 143、c#中的访问修饰符).mp4
0 0 F:\\赵剑宇\\C# 2014Net基础班(赵剑宇)零基础入门 (P143. 145、简单工厂设计模式).mp4
0 0 F:\\赵剑宇\\C# 2014Net基础班(赵剑宇)零基础入门 (P144. 146、序列化和发序列化).mp4
0 0 F:\\赵剑宇\\C# 2014Net基础班(赵剑宇)零基础入门 (P145. 147、仓库的各种货物).mp4
0 0 F:\\赵剑宇\\C# 2014Net基础班(赵剑宇)零基础入门 (P146. 148、导入货物).mp4
0 0 F:\\赵剑宇\\C# 2014Net基础班(赵剑宇)零基础入门 (P147. 149、导出货物).mp4
0 0 F:\\赵剑宇\\C# 2014Net基础班(赵剑宇)零基础入门 (P148. 150、超市类).mp4
0 0 F:\\赵剑宇\\C# 2014Net基础班(赵剑宇)零基础入门 (P149. 151,超市收银系统结束).mp4
0 0 F:\\赵剑宇\\C# 2014Net基础班(赵剑宇)零基础入门 (P150. 152、接口基本语法和用法).mp4
0 0 F:\\赵剑宇\\C# 2014Net基础班(赵剑宇)零基础入门 (P151. 153、接口结束).mp4
0 0 F:\\赵剑宇\\C# 2014Net基础班(赵剑宇)零基础入门 (P152. 154、接口).mp4
0 0 F:\\赵剑宇\\C# 2014Net基础班(赵剑宇)零基础入门 (P153. 155、值传递和引用传递).mp4
0 0 F:\\赵剑宇\\C# 2014Net基础班(赵剑宇)零基础入门 (P154. 156、重写父类中的方法).mp4
0 0 F:\\赵剑宇\\C# 2014Net基础班(赵剑宇)零基础入门 (P155. 157、MD5加密).mp4
0 0 F:\\赵剑宇\\C# 2014Net基础班(赵剑宇)零基础入门 (P156. 158、密封类和部分类).mp4
0 0 F:\\赵剑宇\\C# 2014Net基础班(赵剑宇)零基础入门 (P157. 159、窗体应用程序的基本介绍).mp4
0 0 F:\\赵剑宇\\C# 2014Net基础班(赵剑宇)零基础入门 (P158. 160、button控件的一些简单属性).mp4
0 0 F:\\赵剑宇\\C# 2014Net基础班(赵剑宇)零基础入门 (P159. 161、简单记事儿本应用程序).mp4
0 0 F:\\赵剑宇\\C# 2014Net基础班(赵剑宇)零基础入门 (P160. 162、winform中的各种小程序).mp4
0 0 F:\\赵剑宇\\C# 2014Net基础班(赵剑宇)零基础入门 (P161. 163、多选和单选).mp4
0 0 F:\\赵剑宇\\C# 2014Net基础班(赵剑宇)零基础入门 (P162. 164、MDI窗体设计).mp4
0 0 F:\\赵剑宇\\C# 2014Net基础班(赵剑宇)零基础入门 (P163. 165、图片的上下翻页).mp4
0 0 F:\\赵剑宇\\C# 2014Net基础班(赵剑宇)零基础入门 (P164. 166、Enabled和Visible的练习).mp4
0 0 F:\\赵剑宇\\C# 2014Net基础班(赵剑宇)零基础入门 (P165. 167、下拉框).mp4
0 0 F:\\赵剑宇\\C# 2014Net基础班(赵剑宇)零基础入门 (P166. 168、日期选择器).mp4
0 0 F:\\赵剑宇\\C# 2014Net基础班(赵剑宇)零基础入门 (P167. 169、ListBox).mp4
0 0 F:\\赵剑宇\\C# 2014Net基础班(赵剑宇)零基础入门 (P168. 170、使用ListBox实现双击播放音乐).mp4
0 0 F:\\赵剑宇\\C# 2014Net基础班(赵剑宇)零基础入门 (P169. 171、字体对话框).mp4
0 0 F:\\赵剑宇\\C# 2014Net基础班(赵剑宇)零基础入门 (P170. 172、石头、剪刀、布).mp4
0 0 F:\\赵剑宇\\C# 2014Net基础班(赵剑宇)零基础入门 (P171. 173、简单记事本儿(1)).mp4
0 0 F:\\赵剑宇\\C# 2014Net基础班(赵剑宇)零基础入门 (P172. 174、简单记事本儿(2)).mp4
0 0 F:\\赵剑宇\\C# 2014Net基础班(赵剑宇)零基础入门 (P173. 175、使用GDI绘制一些简单的图形).mp4
0 0 F:\\赵剑宇\\C# 2014Net基础班(赵剑宇)零基础入门 (P174. 176、使用GDI+绘制验证码).mp4
0 0 F:\\赵剑宇\\C# 2014Net基础班(赵剑宇)零基础入门 (P175. 177、多线程).mp4
0 0 F:\\赵剑宇\\C# 2014Net基础班(赵剑宇)零基础入门 (P176. 178、摇奖机程序).mp4
0 0 F:\\赵剑宇\\C# 2014Net基础班(赵剑宇)零基础入门 (P177. 179、Socket网络编程).mp4
0 0 F:\\赵剑宇\\C# 2014Net基础班(赵剑宇)零基础入门 (P178. 180、Socket网络编程).mp4
0 0 F:\\赵剑宇\\C# 2014Net基础班(赵剑宇)零基础入门 (P179. 181、接受客户端的连接和接受客户端发来的消息).mp4
0 0 F:\\赵剑宇\\C# 2014Net基础班(赵剑宇)零基础入门 (P180. 182、服务端和客户端互相守法数据).mp4
0 0 F:\\赵剑宇\\C# 2014Net基础班(赵剑宇)零基础入门 (P181. 183、自己动手写协议).mp4
0 0 F:\\赵剑宇\\C# 2014Net基础班(赵剑宇)零基础入门 (P182. 184、练习1-5).mp4
0 0 F:\\赵剑宇\\C# 2014Net基础班(赵剑宇)零基础入门 (P183. 185、练习6-13).mp4
0 0 F:\\赵剑宇\\C# 2014Net基础班(赵剑宇)零基础入门 (P184. 186、练习15-18).mp4
0 0 F:\\赵剑宇\\C# 2014Net基础班(赵剑宇)零基础入门 (P185. 187、练习19-22).mp4
0 0 F:\\赵剑宇\\C# 2014Net基础班(赵剑宇)零基础入门 (P186. 188、HTML的基本标签框架).mp4
0 0 F:\\赵剑宇\\C# 2014Net基础班(赵剑宇)零基础入门 (P187. 189、HTML中常用标签).mp4
0 0 F:\\赵剑宇\\C# 2014Net基础班(赵剑宇)零基础入门 (P188. 190、HTML中的常用标签).mp4
0 0 F:\\赵剑宇\\C# 2014Net基础班(赵剑宇)零基础入门 (P189. 191、A标签的使用).mp4
0 0 F:\\赵剑宇\\C# 2014Net基础班(赵剑宇)零基础入门 (P190. 192、body当中的属性).mp4
0 0 F:\\赵剑宇\\C# 2014Net基础班(赵剑宇)零基础入门 (P191. 193、列表).mp4
0 0 F:\\赵剑宇\\C# 2014Net基础班(赵剑宇)零基础入门 (P192. 195、table表格).mp4
0 0 F:\\赵剑宇\\C# 2014Net基础班(赵剑宇)零基础入门 (P193. 196、跨行跨列的表格).mp4
0 0 F:\\赵剑宇\\C# 2014Net基础班(赵剑宇)零基础入门 (P194. 197、表格练习).mp4
0 0 F:\\赵剑宇\\C# 2014Net基础班(赵剑宇)零基础入门 (P195. 198、表单(1)).mp4
0 0 F:\\赵剑宇\\C# 2014Net基础班(赵剑宇)零基础入门 (P196. 199、表单).mp4
0 0 F:\\赵剑宇\\C# 2014Net基础班(赵剑宇)零基础入门 (P197. 200、框架标签).mp4
0 0 F:\\赵剑宇\\C# 2014Net基础班(赵剑宇)零基础入门 (P198. 201、HTML结束).mp4
0 0 F:\\赵剑宇\\C# 2014Net基础班(赵剑宇)零基础入门 (P199. 202、CSS的3种写入方式).mp4
0 0 F:\\赵剑宇\\C# 2014Net基础班(赵剑宇)零基础入门 (P200. 203、Css中的样式选择器).mp4
0 0 F:\\赵剑宇\\C# 2014Net基础班(赵剑宇)零基础入门 (P201. 204、字体、背景、和文本的属性).mp4
0 0 F:\\赵剑宇\\C# 2014Net基础班(赵剑宇)零基础入门 (P202. 205、盒子模型和margin、padding).mp4
0 0 F:\\赵剑宇\\C# 2014Net基础班(赵剑宇)零基础入门 (P203. 206、边框属性和display).mp4
0 0 F:\\赵剑宇\\C# 2014Net基础班(赵剑宇)零基础入门 (P204. 207、开学典礼).mp4
0 0 F:\\赵剑宇\\C# 2014Net基础班(赵剑宇)零基础入门 (P205. 208、网页).mp4
0 0 F:\\赵剑宇\\C# 2014Net基础班(赵剑宇)零基础入门 (P206. 209、使用简单工厂设计模式打开指定的文件).mp4
0 0 F:\\赵剑宇\\C# 2014Net基础班(赵剑宇)零基础入门 (P207. 210、面向对象基本语法复习).mp4
0 0 F:\\赵剑宇\\C# 2014Net基础班(赵剑宇)零基础入门 (P208. 211、面向对象(继承)).mp4
0 0 F:\\赵剑宇\\C# 2014Net基础班(赵剑宇)零基础入门 (P209. 212、单例模式).mp4
0 0 F:\\赵剑宇\\C# 2014Net基础班(赵剑宇)零基础入门 (P210. 213、静态和非静态复习).mp4
0 0 F:\\赵剑宇\\C# 2014Net基础班(赵剑宇)零基础入门 (P211. 214、里氏转换机is、as的用法).mp4
0 0 F:\\赵剑宇\\C# 2014Net基础班(赵剑宇)零基础入门 (P212. 215、c#中的5个访问修饰符).mp4
0 0 F:\\赵剑宇\\C# 2014Net基础班(赵剑宇)零基础入门 (P213. 216、需方法和多态).mp4
0 0 F:\\赵剑宇\\C# 2014Net基础班(赵剑宇)零基础入门 (P214. 217、接口).mp4
0 0 F:\\赵剑宇\\C# 2014Net基础班(赵剑宇)零基础入门 (P215. 218、所引器).mp4
0 0 F:\\赵剑宇\\C# 2014Net基础班(赵剑宇)零基础入门 (P216. 219、作业讲解).mp4
0 0 F:\\赵剑宇\\C# 2014Net基础班(赵剑宇)零基础入门 (P217. 220、值传递、引用传递wmv).mp4
0 0 F:\\赵剑宇\\C# 2014Net基础班(赵剑宇)零基础入门 (P218. 221、方法的3个高级参数).mp4
0 0 F:\\赵剑宇\\C# 2014Net基础班(赵剑宇)零基础入门 (P219. 222、字符串的方法).mp4
0 0 F:\\赵剑宇\\C# 2014Net基础班(赵剑宇)零基础入门 (P220. 223、字符串练习).mp4
0 0 F:\\赵剑宇\\C# 2014Net基础班(赵剑宇)零基础入门 (P221. 224、字符串练习).mp4
0 0 F:\\赵剑宇\\C# 2014Net基础班(赵剑宇)零基础入门 (P222. 225、StringBuilder的用法).mp4
0 0 F:\\赵剑宇\\C# 2014Net基础班(赵剑宇)零基础入门 (P223. 226、List泛型集合).mp4
0 0 F:\\赵剑宇\\C# 2014Net基础班(赵剑宇)零基础入门 (P224. 227、键值对集合).mp4
0 0 F:\\赵剑宇\\C# 2014Net基础班(赵剑宇)零基础入门 (P225. 228、装箱和拆箱).mp4
0 0 F:\\赵剑宇\\C# 2014Net基础班(赵剑宇)零基础入门 (P226. 229、文件流和Path类、Directory类).mp4
0 0 F:\\赵剑宇\\C# 2014Net基础班(赵剑宇)零基础入门 (P227. 230、委托语法).mp4
0 0 F:\\赵剑宇\\C# 2014Net基础班(赵剑宇)零基础入门 (P228. 231、匿名函数).mp4
0 0 F:\\赵剑宇\\C# 2014Net基础班(赵剑宇)零基础入门 (P229. 232、求任意数组的最大值).mp4
0 0 F:\\赵剑宇\\C# 2014Net基础班(赵剑宇)零基础入门 (P230. 233、使用泛型委托求任意数组间的最大值).mp4
0 0 F:\\赵剑宇\\C# 2014Net基础班(赵剑宇)零基础入门 (P231. 234、lamda表达式).mp4
0 0 F:\\赵剑宇\\C# 2014Net基础班(赵剑宇)零基础入门 (P232. 235、委托案例:窗体传值).mp4
0 0 F:\\赵剑宇\\C# 2014Net基础班(赵剑宇)零基础入门 (P233. 236、多播委托).mp4
0 0 F:\\赵剑宇\\C# 2014Net基础班(赵剑宇)零基础入门 (P234. 237、创建XML文档).mp4
0 0 F:\\赵剑宇\\C# 2014Net基础班(赵剑宇)零基础入门 (P235. 238、播放器(1)).mp4
0 0 F:\\赵剑宇\\C# 2014Net基础班(赵剑宇)零基础入门 (P236. 239、播放器).mp4
0 0 ";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}