#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m){tex\b([^{}]*({[^{}]*?([^{}]|(?R))*[^{}]*?}[^{}]*)*[^{}]*)}"
Local $sString = "# This is currently a test" & @CRLF & _
"" & @CRLF & _
"{nav Home}" & @CRLF & _
"" & @CRLF & _
"The statistical model estimated the probability, {tex f(x) = \int_{-\infty}" & @CRLF & _
"^\infty \hat f(\xi)\,e^{2 \pi \xi x} \,d\xi }, of capturing dolphins on a tow, {tex i}. A year effect, {tex \lambda_{acb_{j}}} was estimated for each year, {tex j}, allowing for annual variation in the capture event rates that was unrelated to the covariates, {tex x}. The contribution of each covariate, indexed by {tex c}, was governed by a regression coefficient, {tex \beta_c}, that was estimated by the model. The logit transform of the capture event probability was defined as the sum of the year effect, {tex \lambda_{lam} {lam} }, and the covariates:" & @CRLF & _
"{tex \lambda_{lam}{lam} }" & @CRLF & _
"{tex \lambda_{lam} {lam} }" & @CRLF & _
"{tex \lambda_{lam}{lam}}" & @CRLF & _
"katex {{{" & @CRLF & _
"logit(\pi_i) = \lambda_{j[i]} + \sum_c \beta_c x_{ic}." & @CRLF & _
"}}}" & @CRLF & _
"determines the result." & @CRLF & _
"" & @CRLF & _
"# The following is more tests" & @CRLF & _
"" & @CRLF & _
"katex {{{" & @CRLF & _
"f(x) = \int_{-\infty}^\infty" & @CRLF & _
" \hat f(\xi)\,e^{2 \pi i \xi x}" & @CRLF & _
" \,d\xi " & @CRLF & _
"}}}" & @CRLF & _
"" & @CRLF & _
"katex {{{" & @CRLF & _
"\begin{bmatrix}" & @CRLF & _
" a & b \\" & @CRLF & _
" c & a " & @CRLF & _
" \end{bmatrix}" & @CRLF & _
"}}}" & @CRLF & _
"" & @CRLF & _
"katex {{{" & @CRLF & _
"\begin{bmatrix}" & @CRLF & _
" a & c \\" & @CRLF & _
" c & a " & @CRLF & _
" \end{bmatrix}" & @CRLF & _
"}}}" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")