package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^{@(?:[^|]*\|){6}([^|]+)`)
var str = `{@BATCH|ABCDEF|01|12|1||XYZGM|210401113439|online|ATGHDGV03|QGH83826|RevA|||`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}