re = /^(([+-]?(?:\d*(?:\.(?=\d))?\d+))(?:(?:(?:(?<=\d)[Ee])?((?2)))(?<=\d))?)(?:(?<=\d)[, ](?=\d|[+-]|\.)((?1))[iIjJ])?$/
str = '-1.1E-2.2,i'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end