using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(alt|title|src)=(\\""[^""]*\"")";
string input = @"<![CDATA[<img src=\""http://l.yimg.com/a/i/us/we/52/32.gif\""/>\n<BR />\n<b>Current Conditions:</b>\n<BR />Sunny\n<BR />\n<BR />\n<b>Forecast:</b>\n<BR /> Fri - Sunny. High: 23Low: 13\n<BR /> Sat - Thunderstorms. High: 25Low: 15\n<BR /> Sun - Thunderstorms. High: 28Low: 21\n<BR /> Mon - Partly Cloudy. High: 24Low: 17\n<BR /> Tue - Partly Cloudy. High: 26Low: 18\n<BR />\n<BR />\n<a href=\""http://us.rd.yahoo.com/dailynews/rss/weather/Country__Country/*https://weather.yahoo.com/country/state/city-23511893/\"">Full Forecast at Yahoo! Weather</a>\n<BR />\n<BR />\n(provided by <a href=\""http://www.weather.com\"" >The Weather Channel</a>)\n<BR />\n]]>";
RegexOptions options = RegexOptions.IgnoreCase;
Match m = Regex.Match(input, pattern, options);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}