package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`[\*]+([a-z ]*)[\*]+`)
var str = `the *big* brown fox *jumps over* the *lazy* **dog**`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}