re = /^(?:[^a-z]*([a-z])(?=.*(\1[^a-z]*\2?+)$))+[^a-z]*[a-z]?[^a-z]*\2$/
str = 'p alindrome i em ordnilap'
# Print the match result
str.match(re) do |match|
puts match.to_s
end