$re = '/^\+[0-9]{12}$/';
$str = '+123456789012';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);