use strict;
my $str = '<p class="MsoNormal" style="margin: 0in 0in 10pt;"><span style="font-family: "Gill Sans MT","sans-serif"; mso-bidi-font-family: Arial;"><span style="font-size: small;">On Friday, November 13, 2015, at approximately 3:24 p.m., the Sacramento Police Department responded to the intersection of Mabel Street and Silver Eagle Road regarding the report of a shooting.</span><span style="font-size: small;"><span style="mso-spacerun: yes;"> </span></span></span></p>
<p class="MsoNormal" style="margin: 0in 0in 10pt;"><span style="font-family: "Gill Sans MT","sans-serif"; mso-bidi-font-family: Arial;"><span style="font-size: small;">Officers received additional information that the victim’s vehicle, occupied by five juveniles, was driving east-bound on Silver Eagle Road when it stopped at the intersection of Mabel Street.</span><span style="mso-spacerun: yes;"><span style="font-size: small;"> </span></span><span style="font-size: small;">At that time, the unknown suspect(s) fired multiple rounds at the vehicle, striking the driver and the front passenger. </span><span style="mso-spacerun: yes;"><span style="font-size: small;"> </span></span><span style="font-size: small;">The suspect(s) fled the scene in an unknown direction of travel.</span><span style="mso-spacerun: yes;"><span style="font-size: small;"> </span></span><span style="font-size: small;">It is unknown at this time if the suspect(s) were in a vehicle or on foot at the time of the assault.</span><span style="font-size: small;"><span style="mso-spacerun: yes;"> </span></span></span></p>
<p class="MsoNormal" style="margin: 0in 0in 10pt;"><span style="font-family: "Gill Sans MT","sans-serif"; mso-bidi-font-family: Arial;"><span style="font-size: small;">After the shooting, all of the passengers exited the vehicle.</span><span style="mso-spacerun: yes;"><span style="font-size: small;"> </span></span><span style="font-size: small;">One of the passengers put the critically-injured driver in the back seat of the car and drove him to the 1400 block of Grand Avenue.</span><span style="mso-spacerun: yes;"><span style="font-size: small;"> </span></span><span style="font-size: small;">Sacramento Fire Department personnel responded and transported the 17-year-old juvenile to an area hospital where he later succumbed to his injuries. </span></span></p>
<p class="MsoNormal" style="margin: 0in 0in 10pt;"><span style="font-family: "Gill Sans MT","sans-serif"; mso-bidi-font-family: Arial;"><span style="font-size: small;">The remaining juveniles hailed an uninvolved, passerby who transported the front passenger to an area hospital where he is being treated for a non-life threatening injury.</span><span style="font-size: small;"><span style="mso-spacerun: yes;"> </span></span></span></p>
<p class="MsoNormal" style="margin: 0in 0in 10pt;"><span style="font-family: "Gill Sans MT","sans-serif"; mso-bidi-font-family: Arial;"><span style="font-size: small;">Homicide detectives along with Crime Scene Investigators were summoned to the crime scene to begin collecting evidence, and canvassing the area. </span></span></p>
<p class="MsoNormal" style="margin: 0in 0in 10pt;"><span style="font-family: "Gill Sans MT","sans-serif"; mso-bidi-font-family: Arial;"><span style="font-size: small;">A specific motive has not been determined in this incident.</span><span style="mso-spacerun: yes;"><span style="font-size: small;"> </span></span><span style="font-size: small;">The investigation remains very active and no arrests have been made.</span><span style="mso-spacerun: yes;"><span style="font-size: small;"> </span></span><span style="mso-spacerun: yes;"><span style="font-size: small;"> </span></span><span style="mso-spacerun: yes;"><span style="font-size: small;"> </span></span><span style="font-size: small;"><span style="mso-spacerun: yes;"> </span></span></span></p>
<p class="MsoNormal" style="margin: 0in 0in 10pt;"><span style="font-family: "Gill Sans MT","sans-serif"; mso-bidi-font-family: Arial;"><span style="font-size: small;">Sacramento Police Department detectives encourage any witnesses with information to contact the dispatch center at (916) 264-5471 or Crime Alert at (916) 443-HELP (4357) or text in a tip to 274637 (CRIMES). Enter SACTIP followed by the tip information. Callers can remain anonymous and may be eligible for a reward of up to $1,000.</span></span></p>';
my $regex = qr/(\s+)(\S+)=["']?((?:.(?!["']?\s+(?:\S+)=|[>"']))+.)["']?/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}