re = /(?:(?<=>)|^)[^<]+/m
str = '<p>just a small <a href="#">
example</a> link</p><p>to a webpage</p> '
# Print the match result
str.scan(re) do |match|
puts match.to_s
end