#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(?<!\s)$"
Local $sString = "AAAAAA" & @CRLF & _
"BBBBBB" & @CRLF & _
"CCCCCC" & @CRLF & _
"" & @CRLF & _
"DDDDDD" & @CRLF & _
"EEEEEE" & @CRLF & _
"" & @CRLF & _
"FFFFFF" & @CRLF & _
"GGGGGG" & @CRLF & _
"HHHHHH"
Local $sSubst = "\t"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)