using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"LOCATION:(.*)";
string input = @"BEGIN:VCALENDAR X-LOTUS-CHARSET:UTF-8 VERSION:2.0 PRODID:ZMS-Berlin BEGIN:VTIMEZONE TZID:Europe/Berlin X-LIC-LOCATION:Europe/Berlin BEGIN:DAYLIGHT TZOFFSETFROM:+0100 TZOFFSETTO:+0200 TZNAME:CEST DTSTART:19700329T020000 RRULE:FREQ=YEARLY;INTERVAL=1;BYDAY=-1SU;BYMONTH=3 END:DAYLIGHT BEGIN:STANDARD TZOFFSETFROM:+0200 TZOFFSETTO:+0100 TZNAME:CET DTSTART:19701025T030000 RRULE:FREQ=YEARLY;INTERVAL=1;BYDAY=-1SU;BYMONTH=10 END:STANDARD END:VTIMEZONE METHOD:REQUEST BEGIN:VEVENT UID:0.13164400 1467187773 CLASS:pUBLIC DTSTART;TZID=Europe/Berlin:20160628T200000Z DTEND;TZID=Europe/Berlin:20160628T220000Z LOCATION:zu Hause SUMMARY:Test 3 DESCRIPTION:Die Babys sitten END:VEVENT END:VCALENDAR";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}