package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)their(?:s'?|'s)?`)
var str = `theirs|their|their's|theirs'`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}