$re = '/([\"\']|\[\[|\[==\[)(.*?)(((?<!\\\\)\1)|\]\]|\]==\])/';
$str = '" sa\'\\sa " \'a\\\\dsd\' [[asd]] [==[ ad]==] "" \'\' [[]] [==[]==] " "\\\\" "\\"" "\\"\\" "\\" "
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);