$re = '/(?<=Pressure \( \+ or \- \) ).*/m';
$str = 'Pressure ( + or - ) 30 daN
Current ( + or - )';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);