package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)^[0-9]{9}$`)
var str = `222584455`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}