$re = '/\w+[k]\b/m';
$str = 'There was some strange guy which tryed to fuck the rabbit.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);